Skip to content
logo Knowledgebase

Error: 'Cannot open company file. A required data file is missing...'

Created on  | Last modified on 

Summary

How to resolve the error: "Cannot open company file [file name]. A required data file is missing. Check your data directory to be sure the files are there" when opening a data file or restoring from backup in Sage 50 Accounting.

Cause

  • The SAI shortcut or SAJ folder is missing or was renamed
  • The latest version isn’t installed
  • The file is in a synced folder with cloud services like OneDrive, Google Drive, or Drop Box
  • Files in the SAJ folder are hidden

Resolution

File is on Remote Data Access

  1. Re-download the file from Remote Data Access.
    • If you’re having difficulties redownloading,
      • Open the file on another user computer as a sysadmin in single-user mode
      • Go to File, Remote Data Access, Pause Sharing then Resume Sharing
      • Re-download the file on the problem computer again
  2. Save the file on C:\Sage.

Move the file to C Drive

  1. Copy the SAI file and the SAJ folder to a new folder in the C:\\ Drive.
  2. Verify that you can open the file now.

Restore from backup

  1. Restore from the most recent backup.
  2. Verify that the file opens without an error.

Disable antivirus and firewall

  1. Temporarily disable antivirus and firewall.
  2. Verify that the file opens.
  3. If the file opens, set up the antivirus to allow Sage 50 processes.

Verify that both the SAI file and SAJ folder are in the same location

  1. Go to the data file location.
  2. If either SAI file or SAJ folder is missing, locate it and move it back.
    • Both files have to be in one place
  3. If you can't locate the SAI file or SAJ folder, restore from a backup.

Verify that the SAI file and the SAJ folder have matching names

  1. Locate the SAI file and SAJ folder using Windows Explorer.
  2. Make sure the names for both match.
  3. If they don't, rename them with the same name.

Check for missing files or folders in the SAJ folder

Image of the SAJ folder file list.

  1. If any of the above are missing, perform a Windows search for the missing files/folders.
  2. If you can't find these files in a Windows search, restore the company data from a backup.

 

Need more help?

Chat now

 

 

Related Solutions