Error: "Database engine has reported an error" in a network environment
Description
Cause
  • Issues with the shared folder security settings
  • The local system user of the host machine needs permission to the data location
  • Data damage
Resolution

Verify that the sample company opens

Verify that Sage 50 is working properly by opening the sample company.

  • If the sample company opens restart all computers that have Sage 50 installed including the server
    • Verify that the data file opens without an error
  • If the sample company doesn't open, reinstall Sage 50
    • Verify that the data file opens without an error

Disable the firewall

  1. Temporarily disable the firewall at the location where you store the data.
  2. If the file opens after disabling the firewall, set up the firewall to allow Sage 50 processes.

Update the Connection Manager

  1. Update the Connection Manager on the Server computer.
  2. Verify that the data file opens.

Move the company data locally and back to the server

  1. Copy the company file to your local computer.
  2. Open the company data with your Sage 50 locally.
  3. Click File, Save as.
  4. Don't overwrite the original file. Select the server but a different name for the database.
  5. Verify that the new data file opens.

Adjust user permissions

  1. Browse to the location of the SAJ folder for the company.
  2. Right-click the directory and select Properties.
  3. Select the Security tab at the top of the window.
  4. Select Edit.
  5. Select Add.
  6. Type Everyone.
  7. Select OK.
  8. In the Group or User Names section, locate and select the newly added Everyone account.
  9. In the Permissions area, select the first checkbox in the Allow column to grant full control.
  10. Select OK to apply the changes.
  11. Select OK again in the Properties window.
  12. Verify the company file opens.
  13. If the file opens, adjust the user permissions to the appropriate user group. Consult an IT professional for assistance.
     NOTE: It's not recommended to modify this access level as it can post a security risk. Regularly remove Sage 50 access for users who no longer need it. 

End mysqld processes

  1. Have all users close Sage 50 on all computers.
  2. On the server computer, right-click the Windows taskbar and click Start Task Manager.
  3. Go to the Processes tab and click Show processes from all users.
  4. Select all the mysqld.exe or mysqld-nt.exe processes and click End Process.
  5. Reboot the server computer.
  6. Open the file from the workstation.

Damaged or corrupted files

  1. Copy the company file to your local computer.
  2. Open the SAJ folder and locate the errorlog.txt file.
  3. Open the errorlog.txt file in Notepad.
  4. If the file contains hex dump data or large blank space, there's data damage.
    • Example of hex dump data:"00000000000000000000000000000000000000000000000000000000; asc x¤F† 5ÿÿÿÿÿÿÿÿ S%%E¿ H 6 r ² „infimum supremum ŸSystemAdmin - „ äGLView" - „ ÿçGLEdit #> - „ (KAPView $ - „ 0ÿçAPEdit $ - „ 8 ÐARView %0 - „ @ÿçAREdit %• - „ H ƒPrlView &6 - „ PÿæPrlEdit &_ - „ XÿæInvView &¿ - „ `ÿæInvEdit &Þ - „ hþäProjView 'H - „ pÿåProjEdit 'g - „ x Common '† - „ MCommonRW)‹ - „ þlTBView, Ð - „ ÿçTBEdit, ô - „ þ DRFAC 5Œ $3#!)(&%$><":"&^*%SN nBY&^5HH... "
    • Restore the latest working backup or contact Customer Support at 1-888-522-2722 to inquire about data repair services
  5. If the file won't open locally and lacks hex data, run the Company File Check and Repair utility.

 

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