Unable to delete an account from the chart of accounts
Description

This article also addresses the following errors:

  • Error: "You have used this account in transactions this year and cannot remove it until the transactions are cleared."
  • Error: "This account cannot be removed while it is being used as a linked account."
Cause
  • You haven’t finished entering your company's historical information.
  • The account doesn’t have a zero balance.
  • This account is a linked account.
  • Sage 50 is open in multi-user mode.
Resolution
Preparation
  1. Create a backup of your current data before proceeding.
  2. Follow one of the below methods, depending on your situation.

Method 1: If you have multiple users or windows

  1. Switch to single-user mode.
  2. Verify that you can now delete the account.

Method 2: If no entries exist within two years and the balance is 0

  1. Unlink the account.
  2. Verify that you can now delete the account.

Method 3: If your accounts aren’t in logical order

  1. Resolve the error "Your accounts are not in logical order."
  2. Make the account inactive.
Method 4: If the only entries to the account are recent and you can re-enter other recent data
  1. Find a backup made before the posting of entries to this account and restore it.
  2. Restore the backup you found.
  3. Verify you can now delete the account.
  4. Re-enter all other current entries made after that backup.

Method 5: If you have access to Sage 50 Accountant Edition or know an accountant who does

Steps to duplicate
Related Solutions

Re-numbering Accounts
http://help.simplyaccounting.com/cdn-eng/SA2014/AcctEd/Canadian_English/Content/Accountants_Ed-ae/ae-co-ae-AccessClientAccntsFromGJ.htm

Add or Remove Accounts
http://help.simplyaccounting.com/cdn-eng/SA2014/AcctEd/Canadian_English/Content/Accounts-ac/ac-pr-ac-AddRemAccts.htm