Error: "Your accounts are not in logical order. The reason is: ... "
Description
Cause
  • Missing a Header or Total account
  • Missing a group total
  • Missing a subgroup total account
  • You use the types of accounts only to format your financial statements (balance sheet and income statement)
Resolution

 NOTE: Consult your accountant for advice when creating new accounts and making Chart of Accounts changes.

  • Every set of accounts must start with an H account and end with a T account
  • For every sequence of A accounts, there has to be an S account after them
  • Logical sequences (Definitions: H = Header account; G=Group account; A=Subgroup account; S=Subgroup total account; T=Total account)
    1. H,G,T
    2. H, A, S, G, T
    3. H, G, A, S, T
    4. H, A, S, T

Image of the chart of accounts

The account is alone by itself and between a T and an H account

  1. Log in as sysadmin in single-user mode.
  2. Create a backup.
  3. Open the Chart of Accounts.
    • If you are in Classic View, click the Chart of Accounts icon
    • When in Enhanced View, click Company on the left-side pane, then click Chart of Accounts
  4. On the Accounts window, go to the File and click Check the Validity of Accounts.
  5. Check the error message and the account showing on the error. Verify what account shows below and above the account with the issue.
  6. If your account is between a T and an H account, move it before the T or after the H
    account.
    Image of missing Group Heading example.

You’re using Pro

  • Check if you’ve posted any transactions to the account
     NOTE: Someone posted and then reversed the transactions, even if the account balance is zero. Check the general ledger report for this account and select show corrections
  • If you haven’t posted any transactions, delete the account
  • If you posted transactions and want to keep the T or H account number, restore from a backup from before changes
  • If you posted transactions to the account, renumber the account below or above. Make sure to use type H or type T
  • Using the image above as an example
    • Change account 26000 to 25800, to group the new account 25900 with Long-term liability accounts

You’re using Premium or Quantum

Renumber the account.

The account is within a group or series of accounts

  1. Switch to single-user mode.
  2. Open the Chart of Accounts.
  3. On the Accounts window, go to File and click Check the Validity of Accounts.
  4. Check the error message and the account showing on the error. Verify what account shows below and above the group. See sample cases below. It could be one of those errors.
    • Example of Wrong account type
      Image of missing Subgroup Total example.
      The error says a Subgroup Total (S) account is missing above 23300, even though 23400 is already below it. Change the type "G" to "A" subgroup account to correct it.
    •  

      Example of Missing Total or Subgroup Total account
      Image of missing Group Total example.
      This happens when you add a Subgroup (A) account without a Subgroup Total (S), Group (G), and a Group Total (T) account.
    • If there’s room to add the account, create a new S account above 23400 GST: Net.
    • If there’s no room to add the account below the subgroup, and you posted a transaction:
      • Change all type A accounts in a group to type G. Do this only if there's a Type T account at the bottom of that group
      • Renumber the accounts
      • Restore the backup before you created those accounts
  5. Once you've added or changed the account, click Save and Close.
  6. Select File, Check the Validity of Accounts to see if all other accounts are in logical order.
  7. Repeat as necessary according to the error message. 

 

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