Error: "Cannot open company file c:\[Data Path]\[Company filename].sai..."

Summary

How to resolve the error: "Cannot open company file c:\[Data Path]\[Company filename].sai. There is an error connecting to the database" when opening a data file in Sage 50 Accounting.

Cause

  • Expired firewall program is configuring settings for Windows Firewall
  • Multiple antivirus programs on the computer
  • The firewall isn’t configured
  • Damaged MySQL Connector/ODBC
  • Damaged data
  • Network Drive has been disconnected

Resolution

CAUTION: Sage support can't assist with third-party products, hardware, report customizations, or state and federal tax questions. Refer to our Scope of Support for more info. Contact your Sage business partner, network administrator, or accountant for assistance.

Verify the sample company opens

  1. Open the sample company.
  2. If the sample company doesn't open, remove expired antivirus/firewall software from your computer.
  3. Try reopening the sample company and verify that you no longer receive the error message.
  4. Verify you can open your data file.

Sample company opens but data doesn’t open over a network connection

Network Drive disconnected

  1. Verify that there isn’t a red X on the drive.
  2. Open Windows Explorer.
  3. Select your network drive.
  4. If you can now access the drive, try opening the company file again in Sage.
  5. If you’re unable to access that network drive, contact your Local IT to look at your drive mapping.

Firewall not configured

Check location connectivity

  1. Try connecting to the data using the IP address instead of the computer name (or mapped drive).
  2. If other company files from the same location open okay but this one is still not opening, contact Technical Support for a password reset procedure.

Make sure the server and workstation are both set up for private networking

  1. Click the bottom-left Windows icon known as the Start menu.
  2. Type homegroup, then select HomeGroup from the search results.
  3. Select Change network location.
  4. Select Discoverable Yes.
  5. Right-click WiFi or Wired network icon in the system tray.
  6. Select Open Network and Sharing Center.
  7. Verify the network shows as a Private network then close the window and verify that the company will now open

The file is located on an external hard drive

Data location is under Program Files

  • The Program Files folder has restrictive rights that prevent users from accessing certain files/folders
  • Move the data into a newly created folder directly under the C drive

Need more help?

Chat now

 



Solution Properties

Solution ID
221924850015048
Last Modified Date
Wed Aug 27 18:30:01 UTC 2025
Attributes
Product Details
Integrated Product: Blueprints
Views
0