Skip to content
logo Knowledgebase

Error: " The database engine reported an error..."

Created on  | Last modified on 

Summary

How to solve the error: "Sage 50 cannot open the database because the database engine reported an error. See the error log for more information" when opening a Sage 50 Accounting data file.

Cause

  • The data file is still open by Sage 50 (or a 3rd party program)
  • The Connection Manager has stopped working
  • The SAJ folder contains unwanted files
  • Antivirus is blocking Sage 50

Resolution

Restart the Connection Manager

  1. Restart Connection Manager.
  2. Open the file again and verify that the error message is gone.

Move the data to a new folder

  1. Move the SAI file and SAJ folder to the C:\\.
  2. Open the file from there.
  3. Ensure the file isn’t on One Drive, Google Drive, or other cloud services.
  4. Verify that the file opens.

Check the SAJ folder

  1. Ensure the SAJ folder is clean of unwanted items.
  2. Open the file again.

The file is on Remote Data Access

  1. Select Connect to a shared company from the Sage 50 Welcome screen.
    • If you don't have another company file to open, open the sample company
    • Go to File, Connect to a Shared Company
  2. If prompted, log in with your Sage account email address.
  3. Select the company file having the issue and click Download.
  4. Choose the location and file name you would like and click Save.
  5. If you wish to overwrite the existing file, select the same name and location and click Yes.
  6. Verify the data opens normally.

The file is on the Network

Follow the steps to resolve the issue when you’re sharing the data file on a network.

End MySQL task

  1. Close Sage 50 on all the computers.
  2. Open Windows Task Manager of the computer hosting the database.
  3. Select the Process tab.
  4. Check the Show processes from all users button.
  5. End any mysqld.exe (or mysqld-nt.exe) from the Image Name list.
  6. Open your data file again.

Related Solutions

Processes and ports to allow through your antivirus or firewall