Summary
How to solve the error: "Sage 50 cannot open the database because the database engine reported an error. See the error log for more information" when opening a Sage 50 Accounting data file.
Cause
- The data file is still open by Sage 50 (or a 3rd party program)
- The Connection Manager has stopped working
- The SAJ folder contains unwanted files
- Antivirus is blocking Sage 50
Resolution
Restart the Connection Manager
- Restart Connection Manager.
- Open the file again and verify that the error message is gone.
Move the data to a new folder
- Move the SAI file and SAJ folder to the C:\\.
- Open the file from there.
- Ensure the file isn’t on One Drive, Google Drive, or other cloud services.
- Verify that the file opens.
Check the SAJ folder
- Ensure the SAJ folder is clean of unwanted items.
- Open the file again.
The file is on Remote Data Access
- Select Connect to a shared company from the Sage 50 Welcome screen.
- If you don't have another company file to open, open the sample company
- Go to File, Connect to a Shared Company
- If prompted, log in with your Sage account email address.
- Select the company file having the issue and click Download.
- Choose the location and file name you would like and click Save.
- If you wish to overwrite the existing file, select the same name and location and click Yes.
- Verify the data opens normally.
The file is on the Network
Follow the steps to resolve the issue when you’re sharing the data file on a network.
End MySQL task
- Close Sage 50 on all the computers.
- Open Windows Task Manager of the computer hosting the database.
- Select the Process tab.
- Check the Show processes from all users button.
- End any mysqld.exe (or mysqld-nt.exe) from the Image Name list.
- Open your data file again.