Error: 'The database engine reported an error...'
Description
Cause
  • The data file is still open by Sage 50 (or a third-party program)
  • The Connection Manager has stopped working
  • The SAJ folder contains unwanted files
  • Antivirus is blocking Sage 50
  • One of the users has already converted the data file to a higher version
Resolution

When opening a data file in 2026

  1. Go to Windows Start, open the Control Panel and select Programs and Features.
  2. Locate Microsoft Visual C++ 2015-2022 Redistributable (x64) from the list. Right-click on it and click Change/Repair.
  3. Follow the Wizard to complete the repair process.
  4. Repeat the steps for the Microsoft Visual C++ 2015-2022 Redistributable (x86).
  5. Reopen Sage 50.

When opening a 2026 data file in 2025

  1. Install version 2026.
  2. Make sure all users have installed version 2026. This includes users on Remote Data Access.

Restart the Connection Manager

  1. Restart Connection Manager.
  2. Open the file again and verify that there's no error message.

Move the data to a new folder

  1. Move the SAI file and SAJ folder to the C:\\.
  2. Open the file from there.
  3. Ensure the file isn’t on OneDrive, Google Drive or other cloud services.
  4. Verify that the file opens.

Check the SAJ folder

  1. Ensure the SAJ folder is clean of unwanted items.
  2. Open the file again.

The file is on Remote Data Access

  1. Select Connect to a shared company from the Sage 50 Welcome screen.
    • If you don't have another company file to open, open the sample company
    • Go to File, then Connect to a Shared Company
  2. If prompted, log in with your Sage account email address.
  3. Select the company file having the issue and click Download.
  4. Choose the location and file name and click Save.
  5. If you wish to overwrite the existing file, select the same name and location and click Yes.
  6. Verify the data opens normally.

The file is on the Network

Follow the steps to resolve the error: "Database engine has reported an error" in a network environment.

End MySQL task

  1. Close Sage 50 on all the computers.
  2. Open Windows Task Manager of the computer hosting the database.
  3. Select the Process tab.
  4. Check the Show processes from all users button.
  5. End any mysqld.exe (or mysqld-nt.exe) from the Image Name list.
  6. Open your data file again.
Steps to duplicate
Related Solutions

Processes and ports to allow through your antivirus or firewall