Error: "A network error occurred while communicating with the Connection Manager"
Description
Cause
  • Computers are on different networks
  • The Windows version you're using is older than Windows 10
  • The Connection Manager on the computer where the data resides isn't running
  • The Network Location is public rather than private
  • The data folder is compressed
Resolution

[BCB:3:Network warning:ECB]

▼Check the system requirements
  1. Verify that the computer meets the system requirements to run Sage 50.
  2. Ensure the server or data location computer has the latest version of Sage 50 also installed.
  3. If you recently updated Sage 50, verify that you're using the new Sage 50 icon.
▼Disable antivirus and firewall
  1. Temporarily disable the antivirus and firewall.
  2. Verify that you can open the data file.
  3. If the data file opens, contact your IT to allow Sage 50 ports through the antivirus and firewall.
▼Check the Connection Manager
  1. Ensure that the Sage Connection Manager is installed and running on the same server where the data resides.
  2. Check that the connection Manager is running on all other computers that store Sage 50.
  3. Check the Connection Manager's version number on all computers and ensure they're the latest number.
▼Change the network location to private
  1. Right-click the Ethernet or WiFi icon on the taskbar.
  2. Open Network and Internet Settings.
  3. Change the Network Location and Network Profile from Public to Private. Do this on the server and all workstations.
▼Open the company file using the IP address
  1. Click the Sage 50 icon from your desktop.
  2. Select Open an existing company.
  3. In the File name field, type: \\the IP address of the computer where the data is stored\.
  4. Browse to the data file (.sai).
  5. Open the company file.
▼Set up a new shared folder on the C drive
  1. Create a C:\SageData folder, and put a copy of the current data inside.
  2. Go to the Sharing tab and select 'Share this folder with full control to everyone' group.
  3. Go to the Security tab and select 'Share this folder with full control to everyone group'. (if you don't see the everyone group, you can edit it to add it).
▼Check the connectivity between the workstation and the server
  1. On the workstation computer, open the Command Prompt and telnet port 13531 on the server.
  2. If you're unable to telnet to the server, contact a PC Technician to troubleshoot networking issues.
▼Errors when using telnet
  1. Check the firewall settings both on server and workstation computers.
  2. Check the permissions for the Windows user.
  3. Log into Windows as a different user.
  4. Open the ports in the firewall.
  5. Power cycle the router for thirty seconds.
  6. Open the ports in the router.
  7. On the server, open the dbengine.ini file found in C:\Program Files\Winsim\ConnectionManager\MySqlBinary\5.0.38 and add the line "innodb_flush_method=normal".
    • This line modifies the behaviour of the MySQL database, and it's untested
    • This is for servers that are configured with RAID Level two or three
    • Stop and start the connection manager
  8. Ping the server from the workstation and vice versa.
▼Add the server IP address to the workstations that host the file
  1. Open Notepad as Administrator.
  2. Select File, then Open.
  3. Browse to C:\Windows\system32\drivers\etc\hosts.
  4. Select the host file (make sure you're showing all the files in the lower right-hand side).
  5. Go to the end of this file and add a line with the IP address and the name of the server computer. For example, 102.54.94.97 rhino.acme.com.
▼Check the router
  1. Enable Simple File Sharing on the router.
  2. Check the connection speed. A slow network connection will result in this error message.
  3. Configure router to port forward both TCP and with port # 13531 and 13540-13545.
  4. Check if this is an advanced router that contains MySQL features.
  5. If possible, reset the router.
▼Multiple routers
  1. Unplug the internet router cable that is connected to your internal router.
  2. Power off the internal router for 1 minute (remove the power plug to the internal router).
  3. Reconnect the power cable to the internal router again.
  4. Verify that the data file opens.
  5. If the data file opens:
    • The internal router and the internet service provider router are using conflicting IP address ranges
    • Or the internet service provider router is blocking packets via its own firewall
    • Contact your IT administrator to resolve the network problem
▼The data folder is compressed
  1. Check if the folder icon has two blue arrows. This means that the folder is compressed.
  2. To uncheck the option to compress folders:
    • Right-click the folder, select Properties
    • Under the General tab, click Advanced
    • Deselect the option to Compress contents to save disk space and click OK
    • Click Apply, then OK
▼Reboot the server
  1. Reboot the server.
  2. Verify if you can open the file now from the workstation.
▼Install the full version of Sage 50 on the server
  1. Install the full version of Sage 50 on the server.
  2. Check if the data or sample works locally.

 

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