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Error: "The program cannot find an account that is a part of this transaction."

Created on  | Last modified on 

Summary

The article provides solutions for the error message "The program cannot find an account that is a part of this transaction" with three sections: ensuring Account Payable is assigned to the department, checking proper setup of departments, and enabling Departments and Foreign Currencies if needed.

Cause

  • Account payable is not assigned to the department.
  • Currency Exchange and Rounding account not defined or not rounding properly on invoice
  • General Ledger account may have been modified or merged.
  • Departments are not setup.
  • Foreign Currencies are not setup.

Resolution

Section 1: Make sure the Account Payable is assigned to the department

  1. Go to Setup, Settings, General, and Departments.
  2. Click the Assign Accounts button.
  3. Make sure that the Account Payable is listed in the Accounts that use this department.
  4. Click OK to save changes.
  5. Try adjusting the purchase invoice and select the same account.

Section 2: Departments are setup properly

  1. Go to Setup, Settings, Company, Currency
  2. On the account selection on Track Exchange and Rounding Differences in:, change the account to another account temporarily
  3. Click OK
  4. Go back into Setup, Settings, Company, Currency
  5. In Track Exchange and Rounding Differences in change the account back to the proper currency account.
  6. Try to repost invoice

Section 3: Departments and Foreign Currencies are not enabled

  1. Post a negative value invoice to reverse the invoice.
  2. Create a new invoice with the updated information.


Attachment: 220_20230425121022_cannotfindaccount.JPG

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