Summary
"Invalid date. The start date must be between 01/01/1900 and 01/01/2016..."
Cause
- Cannot enter historical transactions for the current year.
Resolution
Method 1: Entering Historical transactions
- Historical transactions can only be entered for dates prior to the earliest transaction date
- If the transaction is dated for the current year, it needs to be entered by the normal process
- For further assistance creating transactions, please see the Related Resources section
Method 2: Damaged Report
- Open the report options window, on the line Template:, choose default report options and try changing the date again
- If in a journal posting window, make sure the date is in your current (or prior) fiscal year. If it is, then close the window and try entering it again. If that doesn't work, close Sage 50, open your file and try again
- If you deleted invoice lookup information (for example by clearing inventory tracking while deleting an inventory item or clearing lookup data in Maintenance, Clear Data), then proceed to Method II
Method 3: Restore a Backup
- Restore the last good backup before the date that has problem printing the reports.
- DocLink: How to restore from a backup
- Redo the entries that were done after that backup.
Method 4: Start New Fiscal Year
- Create a backup
- Start the new fiscal year
- Refer to DocLink: How to advance the fiscal or calendar year
Method 5: Check the date format
- Go to Setup, Settings, Company, Date Format
- Ensure the date is set to mm/dd/yyyy
DocLink: How to enter a customer deposit
DocLink: How to enter a Purchase Invoice
DocLink: How to enter a Sales Invoice
DocLink: How to pay a vendor