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Error: "The Connection Manager Service could not be started..."

Created on  | Last modified on 

Summary

How to fix the error: "The Connection Manager Service could not be started. You need administrator rights on this computer to start the service” when launching Sage 50."

Cause

There are several possible causes for this issue.

  • Windows updates need to be installed
  • Service needs Administrator Rights
  • Service Startup Type set to Disabled
  • Sage 50 Database Connection Manager not starting automatically
  • Damaged Sage 50 program

Resolution

Method 1: Check for Windows updates

  1. Run Windows updates.
  2. Reboot the computer.

Method 2: Use profile with Administrator Rights

  1. Verify that your Windows profile has administrative rights.
    • Go to Control Panel > User Accounts and ensure that you have administrative rights.
  2. Select the Windows Start button > All Programs, then Sage.
  3. Right-click Sage 50 Connection Manager > Run as Administrator.
  4. If prompted for a username and password, type in the required fields and try starting the service again.

Method 3: Check the Startup type

  1. Open the Control Panel > Administrative Tools, then Services.
  2. Right-click the Sage 50 Database Connection Manager and choose Properties.
  3. In General, verify the status of Startup type, if disabled, set it as Automatic.
  4. Select the Log On tab.
  5. Enter the name of your Windows user account and click Apply.
    Note: You can add a password in the User Accounts section of the Control Panel.
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  6. Select the General tab.
  7. Select Start to restart the service, then exit the Services settings.
    • Note: If there’s still an error in starting the Connection Manager, revert to the local system account.

Method 4: Check the Services

  1. Select Start.
  2. Under search program and files, key in 'services', then select Enter.
  3. Select Windows Start > Control Panel > Administrative Tools, then Services.
  4. Double-click on Sage 50 Database Connection Manager.
  5. Change the Startup type: to Automatic.
  6. Select OK.
  7. In the Connection Manager window, select Start Service.
    • Uninstall and Reinstall Sage 50, if you get the error: "The Sage 50 Database Connection Manager service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."

Method 5: Uninstall and Reinstall

  1. Uninstall Sage 50 Accounting.
  2. Reinstall Sage 50 Accounting as administrator, and browse to C:\Sage.
  3. Open the installer files for the Sage 50 version and run the launch.exe as the administrator.
  4. Install any updates when necessary.

Related Solutions

Error 1053 or 1069 when starting the Sage 50 Connection Manager
Error: "Connection Manager Service on Local Computer Started and then Stopped. [...]"