Error: "Connection Manager Service on Local Computer Started and then Stopped. [...]"
Description

What are PUP's?:

See the PC World article: http://www.pcworld.com/article/2603035/these-5-antivirus-suites-keep-potentially-unwanted-programs-pups-from-biting.html

Cause
  • A firewall or other setting is blocking port 13531.
  • The installation process for Sage 50 has been interrupted.
  • Part of it was blocked causing the connection manager and the Connection Manager configuration file to be different names or versions.
  • Severe malware may be on the computer and is preventing specific services on the computer from starting
Resolution
[BCB:4:Operating system warning:ECB]
  • The following steps rely on third party tools (Microsoft Windows) and infrastructure.
  • Sage Support does not provide further assistance.
  • Please enlist the help of a certified Windows technician and/or contact Microsoft Windows if one or more of the steps do not work:
  • Windows Defender may not be sufficient enough to prevent you from all online malware threats. See the Additional information section.

Step 1: Toggle the antivirus

  1. Verify that the version of the connection manager that you are trying to start corresponds to the version of Sage 50 that is installed on your computer.
    • Sometimes the connection manager is updated to the latest version but the latest version of the software is not installed yet.
  2. Turn off your Firewall.
  3. Turn off your Antivirus.
  4. Check to see if the Connection Manager starts now.
    • If it does, then it is your Antivirus or Firewall that is blocking the Connection Manager.
  5. Check Event Viewer for any errors related the the startup of the Sage 50 Connection Manager

Step 2: Reinstall the Connection Manager

  1. The first thing you’ll need to do is identify the name of the service:
    1. So open up Services through the Start menu or Control Panel,
    2. Find the service in the list that you want to delete.
    3. The service name should be "Simply Accounting Database Connection Manager" or "Sage 50 Database Connection Manager" depending on the versions of sage that are installed.
  2. Open the properties by double-clicking on the service name,
  3. Highlight the “Service name” value and copy it to the clipboard.
  4. This is what we’ll need to delete.
  5. Open up a Command Prompt:
    • Windows 7 or Vista: right-click the command prompt and choose Run as Administrator.
  6. The syntax used to delete a service is this:
    • sc delete "ServiceName"
    • If your service name has spaces in it, you’ll need to wrap the service name in quotes, like this:
      • sc delete "Simply Accounting Database Connection Manager"
    • If you recieve an error [SC] OpenService FAILED 1060:, on the command line type in
      • on the command line type: sc query type= service state= all
      • Then re-enter the sc delete "ServiceName" command with the correct service name
  7. Now if you use the F5 key to refresh your Services list, you’ll see that the service is gone.
  8. Once you confirmed the service has been deleted, bring up task manager (CTRL+SHIFT+ESC)
    • On the proccess tab click or check Show proccesses from all users
    • End the Simply.SystemTrayIcon.exe proccess
  9. Go to the appropriate winsim folder:
    • 32 bit computers go to: C:\Program Files\winsim
    • 64 bit computers go to: C:\Program Files (x86)\winsim
    • Delete the ConnectionManager folder
  10. Reinstall Sage 50
    • It will prompt you that Sage is already installed
    • Choose the Update/Reinstall program (Second option)
    • After the reinstall is complete reboot your computer
  11. Open Sage 50 again
DocLink: How do I completely reinstall Sage 50?
Steps to duplicate
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