Program freezes opening or modifying a report

Summary

Sage 50 Accounting freezes and becomes unresponsive when trying to open a report through the Reports menu.

Cause

  • The window displays on a second virtual screen 
  • Windows operating system display configuration issues
  • Monitor setup has changed

Resolution

Preliminary steps

Reboot the computer.

Run Sage 50 with Administrator rights

Right-click the Sage 50 icon and select Run As Administrator.

You have your data synced to a cloud service

  1. See How can I tell if my files are synced to a cloud service?
  2. Move the SAI file and SAJ folder to a folder that doesn't sync to a cloud service.

Change Windows Display Settings

  1. Click Windows Key + P.
  2. Choose Computer Only or PC Screen Only. This will force the options window onto your screen.

 Run the database utilities

  1. Run the database utilities tool.
     NOTE: Locate the tool in the C:\Program Files (x86)\Sage 50 Installation folder. 
  2. Put a checkmark on all four options in the database utility window.
  3. Browse to your company file and click OK.
  4. Reboot the computer.

Reset the Report to Default

  1. Run the Report through the Report Centre.
  2. Choose the appropriate report and click Modify.
  3. Reset the report to Default Template at the top of that screen.
  4. Run the report.
  5. Verify the report works normally from both menus.

Restart the printer spooler

  1. Close Sage 50.
  2. Go to Windows Start, type Services in the Search bar, then open the app.
  3. Locate Printer spooler from the list. Right-click and select Properties.
  4. Click Stop, then Start.
  5. Re-open Sage 50 and try to reopen the report.

The issue occurs with Microsoft print to PDF

  1. Press the Windows key + R, then type 'optionalfeatures.exe'.
  2. Scroll to Microsoft Print to PDF. Uncheck it, then click OK.
  3. Restart the computer.
  4. Go back and check Microsoft Print to PDF again.
  5. Click OK.
  6. Re-open Sage 50 and try to reopen the report.

Re-create the User Account (if unable to see the report for a certain user)

  1. Open Sage 50 in sysadmin single-user mode.
  2. Go to Set up, Set up Users and Roles.
  3. Select that user account and click Remove User.
  4. Click Yes to confirm the removal.
  5. Click Add User to add the user again and then click Close.

 Do a password reset

Call Sage 50 Support at 1-888-522-2722 and request a password override.

Need more help?

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Solution Properties

Solution ID
221924850014551
Last Modified Date
Fri Jan 31 15:24:47 UTC 2025
Attributes
Product Details
Integrated Product: Blueprints
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