Summary
Steps to resolve the error: "An error has occurred while moving the current year to last year. As a result, the new fiscal year could not start. Restore from backup or run Advance Database Check" when advancing the fiscal year in Sage 50 Accounting.
Cause
Historical data problems.
Resolution
Restore from backup
- Find a backup that you haven’t tried to start a new year.
- Restore it under a new name.
- If starting a new fiscal year is successful on the restored data file, re-enter any missing transactions.
- Use the new file as the working data file.
Run the Advanced Database Check (ADC)
- If your data file is on a server, save a copy locally.
- Go to Maintenance, Advanced Database Check (ADC).
ADC is showing some errors
- Create a backup.
- Go to Maintenance, Clear Data, Clear Financial History.
- Remove all historical fiscal years in chronological order.
NOTE: You’ll lose financial history and won’t be able to run comparative historical years financial statements. To retain information on financial statements with historical years in the future, refer to a backup.
- If you can’t remove any fiscal year or there's no historical data, contact support at 1-888-522-2722
- Try starting a new year after removing the financial historical years.
- If you still get an error message, contact support.
ADC is showing no errors
Follow the steps below to check for duplicate years.
Check for duplicate years
- Go to Setup, Settings, Company, Information.
- Ensure you have no duplicate historical dates.
- If the years are duplicated contact customer support.
Move the file to C Drive
- Verify that your data doesn’t reside in a cloud-synchronized folder such as OneDrive.
- Move the SAI and SAJ to a new folder on the C:\\ drive.
- Start the new fiscal year again.