Error: “Cloud backup failed”
Description
Cause
  • The internet connection is too slow
  • The file is too large
  • You don't have sufficient permission to your working directory
  • A firewall or antivirus is blocking the upload
  • Another program or security feature is interfering with the upload
  • Connection Manager hung up or left files open in memory
  • The connection to Microsoft 365 wasn't properly completed
Resolution

Before you start

Make sure that you’ve activated your Microsoft 365 account

Run as administrator

  1. Right-click your Sage 50 icon on the desktop.
  2. Select Run as administrator.
  3. Open your company file.
  4. Create a Cloud Backup.
  5. If successful, modify the Windows permissions on your working directory.
  6. Contact your network technician for more assistance.

Remove the Token cache file

  1. Go to C:\Users\[your user]\AppData\Roaming\Sage\AAD.
    • If you don't see the AppData folder under your username, click View at the top menu and check the Hidden items box
  2. Delete the file with the extension tokencache in this directory.
  3. Go to C:\ProgramData\Sage\Sage Data Exchange.
  4. Delete the file SageDataExchange.sqlite.
  5. Open your company file.
  6. Create a cloud backup.

Test the sample company

  1. Open the Sample company from the welcome page or through C:\Users\Public\Documents\Simply Accounting\[your edition]\Samdata\[your version of Sage 50] – Universl.sai.
  2. Upload the company to Microsoft 365 using your user account.
  3. Create a cloud backup.
  4. If the Backup uploads, follow the next steps to restart the Connection Manager.
  5. If the backup returns the same error, you most likely have an environment-related issue. Contact your IT professional for more assistance.

Restart the Connection Manager

  1. Close Sage 50 Accounting.
  2. Restart Connection Manager.  

Test the Automatic Backup

  1. Go to: Setup/Settings/Company/Backup.
  2. Under Scheduled Backup, select: Automatically back up this file.
  3. Select Create local backup and Browse to OneDrive.

Check your internet upload speed

  1. Open the Internet Speed Test Tool.
  2. Click Start.
  3. Wait for the Download and Upload tests to complete.
  4. If your upload speed is higher than 2mbs, follow the next steps to Check the size of your backup.
  5. If your upload speed is lower than 2mbs, contact your Internet provider or IT for assistance.

Check the size of your backup

  1. Create a local backup (see related resources for more information).
  2. Right-click your backup file, and select Properties.
  3. If the size of your backup file is lower than 700mb, go to Option 8.

Disable Firewall and antivirus

Turn Off Windows Firewall

  1. Go to Control Panel/Windows Firewall.
  2. On the left menu click: Turn Windows Firewall On or Off.
  3. Turn Off all firewalls.

Turn Off Windows Defenders Real-Time Protection

  1. In the Windows search on the task bar, type Settings.
  2. Select Settings from the results.
  3. Go to: Update and security.
  4. On the left menu, click Windows Defender.
  5. Turn Off Real-Time Protection.
  6. Try to create a cloud backup.
  7. If successful, consult your IT professional for assistance or check related resources to set the proper configuration. (Don’t forget to turn your security program back ON).
  8. If Not successful, contact Customer Support via the chat link below.

3rd Party Security Program

  1. Contact your program provider for assistance to disable your Security program.
  2. Try to create a cloud backup.
  3. If successful, consult your Security Program Provider or network technician for assistance in setting the proper configuration. (Don’t forget to turn your security program back ON).
  4. If Not successful, contact Customer Support via the chat link below.

 

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