Error codes: 1603, 1618, 1628, 1701, 1704, 172, and 1722
Description

Any of the error codes may come up during installation and the resolution for all of them is the same.

Cause

Issues with the Windows installation engine and or the Windows registry.

Resolution
[BCB:4:Operating system warning:ECB]

 

  1. Download and run the Microsoft Troubleshooter.
  2. Verify that an antivirus or firewall isn't causing the issue.
  3. Browse to C:\Program Files (x86)\InstallShield Installation Information.
    • Rename (XX before the name) or delete the folder related to the Sage version registry key
  4. Back up the Windows registry (consult your IT professional for this step).
    • Select Windows Start, then Run
    • Type regedit in the Open box, then select OK
    • Highlight My Computer, or Computer
    • Select File, then Export
    • Select All in the Export range, then choose a location to save the registry backup
      • We recommend consulting an IT professional to perform these steps
  5. Remove the registry keys.
    • Select Edit, then Find
    • For 2024, type {07AEA4EE-F4AF-4E3A-8A7B-B3CB7618E27D}
    • For 2025, type {CC48BFD8-5BE3-4450-B7B7-5EC3A3B98AC4}
    • Select Find Next
    • Delete all keys from the registry
    • If the key is in another key folder named 88BCD1C0ED772C5439CCB9153C96A42F in the left pane, delete the whole folder 88BCD1C0ED772C5439CCB9153C96A42F instead
    • Press the F3 key on your keyboard to continue searching for the next key that contains the value
Steps to duplicate
Related Solutions

Error: 0x80040702 "Failed to load dll: Reg 32" when installing Sage 50