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"Bad key file" or "Key file not found" when opening Sage 50 data File

Created on  | Last modified on 

Cause

  • One or more of the key files have been removed from Shared Documents folder location: Windows: C:\Users\Public\Public Documents\Sage Software and as a result a bad key file or key file not found error occurs
  • Some antivirus programs are interfering with Sage 50
  • The Shared Documents folder containing the Sage keyfiles has been moved or deleted manually
  • Malware is affecting the computer
  • Sage 50 has not been activated after installation

Resolution

Option 1: Verify computer setup
  1. A third party application may affect your Sage 50 usage. See Third party utilities, anti-virus and firewall issues with Sage 50 before following the options below.
  2. If there are no third-party utilities installed, run a malware scan. Refer to Method 1: Uninstall malware in article Program doesn't open when opening a file or using the program icon.
  3. Check for expired antivirus software and uninstall or resubscribe as needed.
Option 2: Run as Administrator

 

  1. Right-click on your Sage 50 icon and choose Run as Administrator.
  2. If you still receive the error continue to Option 3.
  3. If you no longer receive the error "Key file not found", this could indicate a permission issue to access the software.
  4. Refer to the article How to Run Sage 50 as Administrator.

Option 3: Verify Activation Status

  1. Open the Sage 50 desktop icon.
  2. When prompted, activate Sage 50.
  3. If the problem isn't resolved, continue to Option 4.

Option 4: Uninstall / Reinstall

  1. In Windows 8.1 and older, go to Start, Control Panel, Programs, and Features.
    • In Windows 10, Right-click on the Start menu and click on Programs and Features / Apps and Features
  2. Select your version of Sage 50 from the list.
  3. Click Uninstall.
  4. Reinstall using Sage 50: Download Portal and the article How do I install Sage 50 Accounting?
    • or install it from the Installer Files folder in C:\Sage

Option 5: Turn off Controlled Folder Access

  1. Select Start, Settings, Update & Security, Windows Security, Virus & threat protection.
  2. Under Virus & threat protection settings, select Manage settings.
  3. Under Controlled folder access, select Manage Controlled folder access.
  4. Switch the Controlled folder access setting to Off.

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