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Error: "Sage 50 cannot find the Connection Manager" when opening the company file.

Created on  | Last modified on 

Description

  • Sage 50 Database Connection Manager does not start at windows startup. 
  • "Error 1053: The service did not respond to the start or control request in a timely fashion". 
  • Do I have to manually stop DHCP Client before I start Sage 50 Database Connection Manager?

Cause

  • Sage 50 Database Connection Manager is not running.
  • Ports and exceptions are not added.
  • Service times out.

Resolution

CAUTION: This solution requires advanced knowledge of Windows security and network settings. Sage isn't responsible for any issues that may arise from changes to these settings. Back up all system and application databases needed for a complete restoration. Consider contacting a certified consultant or your system administrator for assistance.
CAUTION: This solution needs advanced Operating System knowledge. Consult your system administrator for help. Sage isn't liable for issues caused by improper changes to the Windows Registry. Always back up your data before applying advanced solutions.
CAUTION: Sage Customer Support cannot assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Refer to our Scope of Support document for details. For assistance, contact your Sage business partner, network administrator, or accountant. 

Method 1:

  1. Click on Sage 50 Connection manager icon on your task bar (bottom right side beside the clock).
    • Note: If the connection manager icon is not visible, click the Windows Start button, All Programs, Sage, Sage 50 [your edition], Sage 50 Connection Manager.
  2. If the service is stopped, click on Start Service.
  3. If the service is already running (Status Running indicates Yes), click on Stop Service, after it has stopped (Status Running indicates No) then click on Start Service.
  4. Wait a moment until the Status Running indicates Yes.
  5. Click OK.
  6. Try to open the company file again.

Method 2:

  1. Browse to the Windows Control Panel.
  2. Open Administrative Tools.
  3. Double-click Services.
  4. Find and double-click Sage 50 Database Connection Manager.
  5. To start the service, Click Start.
    • or Click Stop followed by Start.
    • if both Start and Stop buttons are greyed out, change the startup from Disabled to Automatic, then attempt to start it.
  6. Click OK.

Method 3:

  1. Get the IP address of the server.
  2. Click on the Start button, type cmd on the Search Box.
  3. Press Enter.
  4. DOS window will show.
  5. Type ipconfig and press Enter.
  6. Take note of the IPaddress - IPv4 Address.
  7. On the local workstation, open Sage 50 and choose Select an existing company.
  8. On the Sage 50 - Open Company Window, under File name type \\ipaddress of the server and press Open.
    • example: \\192.143.20.8
  9. Browse to the server shared folder.
  10. Try to re-open data file.

Method 4:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Backup the registry by going to File-Export, make sure to select All in the Export Range.
  3. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  4. Right-click Control.
  5. Select New.
  6. Click DWORD Value.
  7. In the New Value #1 box, type ServicesPipeTimeout and then press ENTER.
  8. Right click ServicesPipeTimeout and then click Modify.
  9. Click Decimal, type the number of milliseconds that you want to wait until the service times out
  10. Click OK.
    • Typically, a data value of 35,000 is sufficient to keep the service from timing out.
    • However, you can reduce or increase this value according to your specific startup requirements.
    • For example, to wait 60 seconds before the service times out, type 60000.
  11. Close Registry Editor, and then restart the computer.

Method 5:

  1. From the Control Panel, select Administrative tools and Services.
  2. Stop DHCP Client.
  3. Start Sage 50 Database Connection Manager.
  4. If no error message then start DHCP client and follow the instructions below to start the Connection Manager automatically at windows startup.
    • Note: When saving the file attachment rename the extension from .ba to .bat
  5. Download the simplyconnection-DHCP.bat from the attachment. and save it to All Users, STARTUP Folder.
  6. To Access STARTUP folder for All Users:
  7. Right Click on the Start Button.
  8. Click on Open all Users.
  9. Click on Programs and then select the STARTUP folder.
  10. The content of the simplyconnection-DHCP.bat file is as follows:
    @ECHO OFF
    ECHO --------------------------------------
    ECHO -SIMPLY ACCOUNTING CONNECTION MANAGER-
    ECHO --------------------------------------
    ECHO.
    ECHO Stopping DHCP Client. Please Wait....
    NET STOP "DHCP Client"
    ECHO STOPPED
    ECHO.
    ECHO Starting Simply Accounting Connection Manager. Please Wait....
    NET START "Simply Accounting Database Connection Manager"
    ECHO STARTED
    ECHO.
    NET START "DHCP Client"
    ECHO STARTED
    EXIT
  11. You may copy the contents and paste into notepad and save as "simplyconnection-DHCP.bat" file into the All Users startup folder.
  12. Under Services in the control panel, select Sage 50 Connection Manager change startup type from automatic to manual.

Method 6: Use Static IP Address (Consult with your IT Technician before making any changes)

  1. Click on Start and select run.
  2. In the Run Command dialogue box, type cmd.
  3. Click OK (The DOS Prompt will open).
  4. In the DOS Prompt, type ipconfig /all and press ENTER.
  5. Make note of all the settings.
  6. Open the Control Panel.
  7. Select Network Connections.
  8. Right click on Local Area Connection (The Ethernet Adapter displayed in the DOS command prompt).
  9. Click on Properties.
  10. Highlight Internet Protocol (TCP/IP).
  11. Click on Properties.
  12. Fill in the appropriate fields with the information noted earlier, Click on Advanced if would like to enter additional information such as WINS information.
  13. Start Connection Manager.
Attachment: 347_20230425110538_Simplyconnection-DHCP.zip