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My T4 isn’t printing

Created on  | Last modified on 

Summary

Nothing happens when printing my T4 slips.

Cause

  • Printer error or incorrect printer settings
  • Payroll service needs to be updated
  • Trying to print more than 100 T4s

Resolution

Section 1: Printer-related error

 

  • Method 1: When trying to print more than 100 T4's at the same time
    1. Verify if you can print just one T4.
    2. If this works, continue printing your T4's, but in batches of 80 at the same time.
    3. You need 8GB or higher to print T4s. Follow the recommended system requirements rather than the minimum requirements.
  • Method 2: Verify the printer settings
    1. Go to Setup, Reports & Forms.
    2. Select Government Forms, Federal Payroll.
    3. Select the desired Printer under the T4 Slips and T4 Summary Printer Settings section.
    4. Do the same for the Record of Employment Printer Settings section.
  • Method 3: Check the printer to see if it works outside of Sage 50
    1. Open another non-Sage program (Word, Notepad or Excel).
    2. Try to print something. If it doesn’t print, verify the printer settings.
    3. If the printer does work continue to Method 4.
  • Method 4: Reboot
    1. Reboot your computer.
    2. Verify that you can now print.
  • Method 5: Try switching the printer to a different one
    1. Go to Set up, Reports and Forms.
    2. Select the form type.
    3. Change the printer (you can test with Microsoft PDF).
    4. Select OK.
  • Method 6: Reset the selected printer for the T4 forms to Default
    1. Go to Setup, Reports and Forms, Government Forms.
    2. Select each Setup... button, then click OK.
    3. Select OK.

Section 2: Payroll Service plan issue (plan not activated or expired or need to subscribe)

  1. Go to Help and select About Sage 50...
  2. Click Support Info.
  3. Check the version. You need to be on the latest version of Sage 50.
  4. If your Payroll service plan is active, it will show Payroll ID (Active).
  5. If it doesn’t say 'Active', and you know you’ve paid for a subscription,
    • Go to Help, Update Service plan, Check service plan
    • If it doesn’t work, call Sage 50 Customer Service at 1-888-222-8985 to check your payroll service

Section 3: Program or OS-related problem

  • Method 1: Check if you can print T4 from the sample company
    1. To open the sample company, go to C:\Users\Public\Public Documents\Simply Accounting\202X\Samdata\Pro.
    2. If the T4 prints fine from the sample company and your company file is on the network, save your current data file locally and try printing again.
    3. If you can reproduce the issue in the sample company file: Make sure you’re able to access the "Document\Simply Accounting\forms" folder.
    4. The T4 won't print if you don’t have full rights (read/write) on the "forms" folder.
  • Method 2: Reinstall Sage 50
    1. Close Sage 50.
    2. Open the Control Panel from the Windows Start menu.
    3. Click Programs & Features.
    4. Reinstall Sage 50 by checking the update/reinstall option.
    5. Reboot the computer.


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