Summary
Nothing happens when printing my T4 slips.
Cause
- Printer error or incorrect printer settings
- Payroll service needs to be updated
- Trying to print more than 100 T4s
Resolution
Section 1: Printer-related error
- Method 1: When trying to print more than 100 T4's at the same time
- Verify if you can print just one T4.
- If this works, continue printing your T4's, but in batches of 80 at the same time.
- You need 8GB or higher to print T4s. Follow the recommended system requirements rather than the minimum requirements.
- Method 2: Verify the printer settings
- Go to Setup, Reports & Forms.
- Select Government Forms, Federal Payroll.
- Select the desired Printer under the T4 Slips and T4 Summary Printer Settings section.
- Do the same for the Record of Employment Printer Settings section.
- Method 3: Check the printer to see if it works outside of Sage 50
- Open another non-Sage program (Word, Notepad or Excel).
- Try to print something. If it doesn’t print, verify the printer settings.
- If the printer does work continue to Method 4.
- Method 4: Reboot
- Reboot your computer.
- Verify that you can now print.
- Method 5: Try switching the printer to a different one
- Go to Set up, Reports and Forms.
- Select the form type.
- Change the printer (you can test with Microsoft PDF).
- Select OK.
- Method 6: Reset the selected printer for the T4 forms to Default
- Go to Setup, Reports and Forms, Government Forms.
- Select each Setup... button, then click OK.
- Select OK.
Section 2: Payroll Service plan issue (plan not activated or expired or need to subscribe)
- Go to Help and select About Sage 50...
- Click Support Info.
- Check the version. You need to be on the latest version of Sage 50.
- If your Payroll service plan is active, it will show Payroll ID (Active).
- If it doesn’t say 'Active', and you know you’ve paid for a subscription,
- Go to Help, Update Service plan, Check service plan
- If it doesn’t work, call Sage 50 Customer Service at 1-888-222-8985 to check your payroll service
Section 3: Program or OS-related problem
- Method 1: Check if you can print T4 from the sample company
- To open the sample company, go to C:\Users\Public\Public Documents\Simply Accounting\202X\Samdata\Pro.
- If the T4 prints fine from the sample company and your company file is on the network, save your current data file locally and try printing again.
- If you can reproduce the issue in the sample company file: Make sure you’re able to access the "Document\Simply Accounting\forms" folder.
- The T4 won't print if you don’t have full rights (read/write) on the "forms" folder.
- Method 2: Reinstall Sage 50
- Close Sage 50.
- Open the Control Panel from the Windows Start menu.
- Click Programs & Features.
- Reinstall Sage 50 by checking the update/reinstall option.
- Reboot the computer.