Description
This problem started because the hosts file (used to store information on where to find a computer on the network) may have been modified by malicious or potentially unwanted software. On March 9, 2009 a signature (update) for Windows Defender started detecting these modifications. You can find detailed information about this issue on the Microsoft website.
Cause
- Hosts file modified
- Data is located under a different user account
Resolution
CAUTION: This solution needs advanced Operating System knowledge. Consult your system administrator for help. Sage isn't liable for issues caused by improper changes to the Windows Registry. Always back up your data before applying advanced solutions.
CAUTION: Sage support can't assist with third-party products, hardware, report customizations, or state and federal tax questions. Refer to our Scope of Support for more info. Contact your Sage business partner, network administrator, or accountant for assistance.
Solution I: Hosts file
- Step I: Open Notepad as the Administrator
- Open the Start menu
- Type Notepad in the Search box
- Right-click on it from the list
- Select Run as Administrator (or Run as... and then Administrator)
- Step II: Open the hosts file
- Select File, Open
- Change the file type from Text documents (*.txt) to All files (*.*)
- Open the C:\WINDOWS\system32\drivers\etc\hosts file
- Add the following line at the beginning of the file (please, ignore all the lines with the # sign at the beginning):
127.0.0.1 localhost - Save the changes.
- Test Sage 50.
- If you get a message from Windows defender with information about Win32 HostsFileHijack, click on Ignore.
- If Sage 50 does not work, restart the computer and test it again. Note: Sage 50 may take one or two minutes to open.
- Please follow the previous steps again if you solved the issue for one Windows user, but a second user gets the same problem.
Solution II: Multiple Network Cards
- If sharing the data across a network, opening and closing companies may generate this message if the server has more than one Network card. This will cause the connection manager to be confused as to which network card to use. If a user has left the program opened for an extended period of time without any activity the server security may shut down the connection manager. Check the security logs and configurations and again event viewer. The Simply Accounting development team is working on this issue.
- If you have recently installed Sage 50 2014, make sure to check that the connection manager on the server is version 3.0. Double click on Sage 50 connection manager properties icon in the right hand corner of your task bar in your computer.
Solution III: Network Adapter settings
- Navigate to Control Panel, Device Manager, Network Adapters, and double click on your network adaptor.
- Click on the Power Management tab and deselect Allow the computer to turn off this device to save power.
- Ensure this is done on all computers.
Solution IV: Third Party programs interfering
- Refer to Related Resources "Program doesn't open when opening a file or using the program icon" (47945)
Solution V: Run as Administrator
- Right click on the shortcut icon for Sage 50
- Click Properties
- Click on Compatibility tab
- Check mark the box for Privilege Level, Run this program as an administrator
- This is for a regular workstation not using a Terminal Server
Solution VI: Data is located under another User Account
- Open Windows Explorer and go to the location of the data.
- Copy both the .saj and .sai
- Create a new folder directly under the C drive. (ie: Accounting Data)
- Paste the .saj and .sai into the newly created folder.
- Open Sage 50 to the Welcome screen.
- Choose Select an existing company
- Guide the window to the newly created folder.
- Open the .sai file.
Solution VII: Active Directory
Ensure the Documents folder of the computer with the error message has proper security permissions on the folder.