Erreur : " Le moteur de base de données a signalé une erreur... "
Description
Cause
  • Le fichier de base de données est toujours ouvert par Sage 50 (ou un programme tiers)
  • Le gestionnaire de connexion sur le serveur n'est pas de la même version que sur le poste de travail
  • Les autorisations sur le répertoire .SAJ ne comprennent pas un accès complet pour le compte Système
  • L'antivirus bloque mysql, entravant la conversion. Désactivez l'antivirus, restaurez la sauvegarde et convertissez à nouveau
  • Un des utilisateurs a déjà converti le fichier de données vers une version supérieure
Resolution

Lors de l'ouverture d'un fichier de données dans 2026

  1. Allez dans Démarrer de Windows, ouvrez le Panneau de configuration et sélectionnez Programmes et fonctionnalités.
  2. Repérez Microsoft Visual C++ 2015-2022 Redistributable (x64) dans la liste. Faites un clic droit dessus et cliquez sur Modifier/Réparer.
  3. Suivez l’assistant pour terminer le processus de réparation.
  4. Répétez les étapes pour Microsoft Visual C++ 2015-2022 Redistributable (x86).
  5. Rouvrez Sage 50.

Lors de l'ouverture d'un fichier de données 2026 dans 2025

  1. Installez la version 2026.
  2. Assurez-vous que tous les utilisateurs ont installé la version 2026. Cela inclut les utilisateurs avec Accès aux données à distance.

Redémarrer le gestionnaire de connexion

  1. Redémarrez le gestionnaire de connexion.
  2. Ouvrez à nouveau le fichier et vérifiez que le message d'erreur a disparu.

Déplacer les données vers un nouveau dossier

  1. Déplacez les dossiers .SAI & .SAJ vers le C:\\.
  2. Ouvrez le fichier à partir de là.
  3. Assurez-vous que le fichier n'est pas sur One Drive, Google Drive ou d'autres services cloud.

Vérifier le dossier SAJ

  1. Assurez-vous que le dossier SAJ ne contient aucun élément indésirable.
  2. Ouvrez à nouveau le dossier.

Le fichier se trouve sur Accès aux données à distance

  1. A partir de l'écran d'accueil, sélectionnez Se connecter à une entreprise partagée.
    • Ou à partir d'un fichier d'entreprise existant qui peut s'ouvrir, cliquez sur FichierConnexion à une entreprise
  2. Connectez-vous avec votre adresse e-mail de compte Sage si vous y êtes invité.
  3. Sélectionnez le fichier de l'entreprise avec le problème et cliquez sur Connecter.
  4. Choisissez l'emplacement et le nom de fichier souhaités et cliquez sur Enregistrer.
  5. Si vous souhaitez écraser le fichier existant qui présente l'erreur, sélectionnez le même nom et emplacement que celui où le fichier a été enregistré et cliquez sur Oui.
  6. Après le téléchargement et la synchronisation du fichier de l'entreprise, il devrait s'ouvrir normalement.

Terminer la tâche MySQL

  1. Fermez Sage 50 sur tous les ordinateurs.
  2. Ouvrez le Gestionnaire des tâches de Windows de l'ordinateur hébergeant la base de données.
  3. Sélectionnez l'onglet Processus.
  4. Cochez la case Afficher les processus de tous les utilisateurs.
  5. Mettez fin à tout mysqld.exe (ou mysqld-nt.exe) de la liste des noms de processus d'arrière-plan.
  6. Ouvrez à nouveau votre fichier de données.
Steps to duplicate
Related Solutions