Error: "Bad key file" or "Key file not found"
Description
Cause
  • One or more of the key files have been removed from the Shared Documents folder location: Windows: C:\Users\Public\Public Documents\Sage Software
  • Some antivirus programs are interfering with Sage 50
  • The Shared Documents folder containing the Sage keyfiles has been moved or deleted manually
  • Malware is affecting the computer
  • Sage 50 hasn’t been activated after installation
Resolution

Verify computer setup

  1. Verify that a third-party application isn't affecting your Sage 50 usage.
  2. If there are no third-party utilities installed, run a malware scan
  3. Check for expired antivirus software and uninstall or resubscribe as needed.

Run as Administrator

  1. Run Sage 50 as Administrator.
  2. If you still receive the error, proceed to the next steps.
  3. If you no longer receive the error, this could indicate a permission issue to access the software.

Verify Activation Status

  1. Open the Sage 50 desktop icon.
  2. When prompted, activate Sage 50.
  3. If the problem isn't resolved, continue to the next steps.

Uninstall and reinstall Sage 50

  1. Go to Windows Start, Control Panel, Programs and Features.
  2. Select your version of Sage 50 from the list.
  3. Click Uninstall.
  4. Reinstall Sage 50.
    • Or install it from the Installer Files folder in C:\Sage

Turn off Controlled Folder Access

  1. Select Start, Settings, Update & Security, Windows Security, Virus & threat protection.
  2. Under Virus & threat protection settings, select Manage settings.
  3. Under Controlled folder access, select Manage Controlled folder access.
  4. Switch the Controlled folder access setting to Off.

The computer is freezing up with the bad key file message

See The computer freezes when the Session Date pops up.

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