Can’t print a report or form to a specific printer tray
Description
Cause
  • Something is blocking the printer tray, and you couldn’t see the obstruction during casual inspection.
  • The desired tray had no paper, or the printer couldn’t recognize or grab paper from it.
  • The printer has an obsolete driver installed, so the printer didn’t understand tray selection commands.
  • A generic or wrong printer driver controlled the printer, causing tray selection problems.
  • A driver from manufacturer A controlled a printer from manufacturer B.  The printer didn't understand the command.
  • Regular printing worked because both manufacturers shared base programming from HP’s laser jet standards.
  • The driver was wrong and only offered Tray 1 and Tray 2, not the desired Tray 3.

 

 

 

 

Resolution

 NOTE: Printer drivers differ in their capabilities. Not all printers are capable of tray selection. Not all printer drivers can receive input from Sage 100 to print to a particular tray. Sage 100 Customer Support offers the following suggestions based on what has worked for some customers in the past, but can’t guarantee success. Sage 100 Customer Support suggests working with your Sage business partner or IT professional for trial-and-error testing or troubleshooting of tray selection problems.

If the correct tray was working before, reset the Print Spooler

  1. In Windows, Control Panel, Administrative Tools, Services.
  2. Right-click on the Print Spooler service. Stop it.
  3. After it stops, right-click it again and select Restart.
  4. Try printing again.

 TIP: If you selected Use Multi-part printing when printing a form, then it will only show multi-part enabled/configured printers and other printers won’t appear. You can test with another Form Code that doesn’t have multi-part printing selected. 

If the issue persists

  1. Install a new printer driver and set the default tray in Printer Preferences.
  2. Name the new printer with the tray number to differentiate it from other drivers.
  3. On the printing task window, select the printer, click Setup, and choose the tray in Preferences.
  4. Edit the report in Crystal Reports Designer, select No Printer in Page Setup, or specify the printer.
  5. Save the updated form or report after changing Crystal Reports Designer.
  6. Try installing another driver, such as a generic PCL6 driver, if issues continue.
  7. For Crystal Report forms, enable Multi-Part Printing even if only one printer uses a specific tray.

 

[BCB:155:Chat 100 US:ECB]
Steps to duplicate
Related Solutions

How to add the Designer button to report or form printing task windows (to launch Crystal Reports Designer)
Can’t print to a thermal or label printer (such as a Dymo or Zebra or Brother QL series)
How to setup and use Multi-Part Form Printing in Sage 100
How to troubleshoot printing problems in Sage 100