Error: "Failed to retrieve data from the database" (ODBC DSN not configured properly)
Description
Cause

The ODBC data source configuration doesn’t match the Crystal report.

Resolution

Verify that you configured your Timberline Data Source DSN properly.

  1. Go to the Windows Start button, All Programs, ODBC.
  2. Select the correct administrator for your version.
    • Versions 25.2 and earlier: 32-bit ODBC Administrator
    • Versions 26.1 and later: 64-bit ODBC Administrator
  3. Go to the System DSN tab.
  4. Select the Timberline Data Source.
  5. Select Configure.
  6. Click Select Folder and then select the folder that contains the data you want to use.
  7. Click OK.
  8. Click Options.
  9. Specify the Table and Field Naming as Standard Descriptions.
  10. Check the Use maximum table segment size checkbox.
  11. Clear the Shorten field and table names checkbox.
  12. Click OK twice.

If the message persists, use Set Location and Verify Database on the report.

Steps to duplicate
Related Solutions

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