Error: "Failed to retrieve data from database" (non-admins can't print invoices)
Description

The error happens when non-Application Administrator users attempt to preview invoice formats for Contract-Based Invoices in the Invoice Formats screen. It also occurs if they try to print a final invoice using one of these formats. This issue only affects some specific invoice formats. In contrast, Application Administrators can preview and print all formats without encountering errors.

Cause

This issue occurs due to a combination of security and not having all applications installed (such as Project Management).

Resolution

We'll provide a fix in a future release.

Known workarounds

Use a different invoice format

If an invoice format references an application that you don't know, you can receive the error. Select a format that doesn't reference unowned applications.

For example, the two invoice formats attached below have had all Project Management fields removed on the Billing Invoice Format Crystal sub-reports. You can use these as a basis for users who aren't admins. Contact your Sage Consultant for assistance.

Attachment: NL_L-PB no PJ detail no stored.crs
Attachment: NL_L-PB no PJ detail with stored.crs

If you’re using a custom invoice design based on a Sage design, use Crystal reports to remove sub-reports from the header. Remove the NL_H_PJ CO.crx and NL_H_PJ CO Addons.crx sub-reports from Report Header d. Contact Sage Support for assistance.

Update the user's permissions

Update Billing users to give them Application Administrator rights in Security Administration.

Use a different invoice sub-report

If you use invoice sub-reports instead of a specific invoice design, you can change the Detail sub-report to one that doesn't include unowned applications.

For example, instead of the Contract Summary with Vertical Layout, you can use a non-PJ Detail sub-report such as Subcontractor's Application for Payment.

Print draft invoice for review

Have the limited user print a draft to pdf that they can review before printing. After review, an Application Admin can do a Print Final for the invoice.

 



Steps to duplicate
Related Solutions

Error: "Failed to retrieve data from the Database" (Troubleshooting)