The automatic federal or provincial payroll tax calculation is incorrect
Description
Cause
  • Incorrect incomes and/or benefits settings
Resolution

Check the Canada Revenue Agency (CRA) payroll calculator

  • Compare the tax calculations to the CRA Payroll Deduction Online Calculator (PDOC) 
  • For Quebec, use WEBRAS or the WINRAS tool
  • Ensure that the calculations are based on the Gross Pay and not Net Pay
  • Make sure that you have a Business Care plan that includes automatic payroll calculation
  • If the calculations in Sage 50 match the PDOC calculator results, they're correct
  • We recommend that you speak with a certified accountant or CRA to validate the employee setup

Check the calculation on a different computer

  • Do the same paycheque on a different computer to check if it’s generating the same numbers
  • If calculations are correct on the second computer, this is a computer issue
  • Contact a computer technician to format the computer where you're getting incorrect amounts

Install the latest tax update

  1. Verify you have the latest payroll tax update.
  2. If the tax tables aren't current, install the update.

 NOTE: The 2025.2 Sage 50 update contains the new payroll tax changes effective July 1. Install the update and update employee claims before processing payroll. 

Update employees personal tax credits

  1. Update employee basic personal amounts.
  2. Update these amounts on January 1 for that year.
  3. Payroll tax calculation is based on the claim amounts at the time you post the paycheque.
  4. If you posted a paycheque and then updated the claim amounts after, the taxes are incorrect.
  5. Adjust any paycheques you posted with incorrect claim amounts.

Check the deductions settings

  1. Go to Setup, Settings, Payroll, then Incomes.
  2. Ensure that all active income types have the Calc. Tax option enabled.
  3. Select Deductions.
  4. Ensure that appropriate deductions have the Deduct After Tax option enabled or disabled.
  5. Select Linked Accounts, then Taxes.
  6. Ensure that all the payables, expenses, and payment adjustments tax fields are linked to the correct account.
  7. Check the linked accounts opening balances and make sure they're correct.
    • Review this information with your accountant
  8. Ensure the start date and end date of your report are from January 1 to December 31.

 NOTE: Incorrect deductions settings or updating settings mid-year will cause incorrect income tax calculations. 

Check the EI and CPP settings

  1. Go to Employees & Payroll, then Employees.
  2. Double-click an employee to open the profile, and select the Taxes tab.
  3. Select the Deduct EI checkbox and verify the employer rate is correct.
  4. Select the Deduct CPP/QPP checkbox.
  5. Repeat the steps for all active employees.

Check the employees pay periods

Recalculate taxes on manual paycheques

  1. If you created or adjusted paycheques manually, verify that the income tax amounts are correct.
  2. Go to the paycheque in question and click Recalculate Taxes.

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