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I am unable to add a new vendor or customer

Created on  | Last modified on 

Summary

Steps to resolve issues adding a vendor or customer in Sage 50 Accounting.

Cause

The inability to add a vendor may be caused by a corrupt vendor record, corrupt Sage user account, or a corrupt Sage User ID

Resolution


Method 1: Corrupt Sage User
  1. Log into Sage using a different user.
  2. If you are able to create a new vendor using a different user, create a new user in Sage and remove the old user ID.
  3. If all users have the issue, save a test copy of the file and remove all users one by one, testing between each. Once you find the problem user, delete and recreate it.

Method 2: The corrupt vendor record is known

  1. Find an inactive vendor with $0 balance and activate them and clear all paid transactions and lookup data for them.
  2. Merge the corrupt vendor record into the recently activated vendor record.
  3. If it is successful, update the record info for the vendor record to that of the corrupt record (name, address, etc.)
  4. Try adding a new vendor record. If it doesn't work, proceed to Method 3.

Method 3:

  1. Open the company file in single-user mode and as "sysadmin" user name.
  2. Click Setup.
  3. Click User Preferences.
  4. Click View.
  5. Deselect Customers & Sales / Vendors & Purchases.
  6. Click OK.
  7. Repeat steps 2 to 4.
  8. Select Customers & Sales / Vendors & Purchases again.
  9. Click OK.

Method 4:

  • Have a password reset performed. 

Method 5:

  • Select Maintenance, Database Utilities, then Repair Security

Method 6: The corrupt vendor record isn't known

  • Contact Sage Support to see if the file can be repaired

 

 

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