Summary
Steps to resolve issues adding a vendor or customer in Sage 50 Accounting.
Cause
The inability to add a vendor may be caused by a corrupt vendor record, corrupt Sage user account, or a corrupt Sage User ID
Resolution
Method 1: Corrupt Sage User
- Log into Sage using a different user.
- If you are able to create a new vendor using a different user, create a new user in Sage and remove the old user ID.
- If all users have the issue, save a test copy of the file and remove all users one by one, testing between each. Once you find the problem user, delete and recreate it.
Method 2: The corrupt vendor record is known
- Find an inactive vendor with $0 balance and activate them and clear all paid transactions and lookup data for them.
- Merge the corrupt vendor record into the recently activated vendor record.
- If it is successful, update the record info for the vendor record to that of the corrupt record (name, address, etc.)
- Try adding a new vendor record. If it doesn't work, proceed to Method 3.
Method 3:
- Open the company file in single-user mode and as "sysadmin" user name.
- Click Setup.
- Click User Preferences.
- Click View.
- Deselect Customers & Sales / Vendors & Purchases.
- Click OK.
- Repeat steps 2 to 4.
- Select Customers & Sales / Vendors & Purchases again.
- Click OK.
Method 4:
- Have a password reset performed.
Method 5:
- Select Maintenance, Database Utilities, then Repair Security
Method 6: The corrupt vendor record isn't known
- Contact Sage Support to see if the file can be repaired