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Employer EI amount calculating incorrectly

Created on  | Last modified on 

Summary

Steps to take when the employer EI amount is not calculating correctly.

Description

Cause

  • The EI factor specified for a new employer is not correct.
  • The EI factor specified in one or more employees' record is not correct.

Resolution

Step 1: Check the setting for new employee

  1. Select Setup, Settings, Payroll, then Taxes.
  2. Confirm the EI Factor for new employees is correct.

Step 2: Check the setting in each employee record

  1. Select Employees & Payroll, then Employees.
  2. Open each employee record and select Taxes tab.
  3. Confirm the Rate field to the right of the Calculate EI is correct.

Note: The rate that is shown in both of these locations should be the employer EI rate and not the employee EI rate.