Error: "This transaction can't be adjusted..." when selecting adjust

Summary

How to resolve the errors where a transaction can't be adjusted.

Description

Example errors include, but are not limited to:

  • "This transaction cannot be adjusted because the transaction date occurred before the previous year."
  • "Because this transaction is dated in the previous calendar year, all amounts must be entered manually."
  • "This transaction is dated in the previous fiscal year. Only current fiscal year transactions can be adjusted automatically. You must adjust this transaction manually."

Cause

  • The transaction is dated before the prior fiscal year
  • The transaction number (for example, the invoice number is the same for both transactions)

Resolution

Option 1:

  1. Restore a backup

Workaround:

  1. Create an exact negative version of the problematic transaction (the one posted in this fiscal year).
  2. If it also requires clearing (such as Payments or Receipts), then apply a neutral payment or receipt for the positive and negative invoice.
  3. Create a new positive version of the problematic transaction, but this time, do not use the same transaction number.

Note: Any Transaction dated before the prior fiscal year cannot be changed. The above workaround can allow the reversal and creation of the transaction by creating a negative duplicate transaction in the current year, followed by another transaction created with the correct information.

Solution Properties

Solution ID
222924250017728
Last Modified Date
Mon Nov 21 17:54:25 UTC 2022
Attributes
Product Details
Integrated Product: Blueprints
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