Summary
Error: "The program detected an error in your data when looking for information related to record. You may want to restore your latest backup."
Description
Error occurs when attempting to convert data
Error occurs when converting data to Sage 50 2018 from an older version and conversion log references a .sfm file
When running an income statement, it crashes with this error message
Cause
- Name of program files folder has extra characters: the path to Sage 50 forms is wrong
- Firewall or antivirus blocking the program
- Damaged form file
- Outdated Windows OS
Resolution

Notes:
- After a conversion to a new version fails, a conversion log is created inside the .SAJ folder of the company file that failed to convert.
- The .SAJ folder is in the same location as the sage 50 data file that you would click on to open the company.
- If during the conversion you get error: "The program detected an error in your data when looking for information related to record", open the .SAJ folder and look for the conversion log. the name of the .txt file will be the date and the time of the failed conversion.
- Open that file and scroll to the very bottom.
- If the last 2 or 3 lines reference a .sfm file, use method 3.
- If you have trouble locating the .SAJ or the conversion log, please contact support.
Preliminary check:
- Sage 50 2020.2 and the Connection Manager will not run on Windows 8 and Windows Server 2012 with Build 9200
- go to command prompt and run 'winver' to check your Windows OS Build
- If the system is out of date, then do a Windows update to Server 2012 R2 or Server 2016 or Windows 8.1 or higher
Method 1:
- Open Windows File Explorer and go to C:\Program Files (x86)
- Identify the folder containing the latest version of Sage 50 and check if the name of the folder ends with “Trial Version”.
- If it does, shorten the name of the folder by removing “Trial Version”.
- Try to convert the data file again.
Method 2:
- Disable your firewall and/or antivirus.
- Try converting again
- Once conversion is completed, update firewall or antivirus to allow Sage 50
- See Related Resources for information on processes to allow through your firewall
- Enable your firewall and/or antivirus
Method 3:
- Uninstall and reinstall the new version of Sage 50 as administrator
Method 4:
- Check conversion log for name of customize form file causing the problem. The file name will be listed as *filename*.sfm in the last few lines of the conversion log
- Open the company file in the old version of the software and go to setup, reports and forms
- Change the form setting using the damaged .sfm file to a default form and attempt to convert again
- If the file still does not convert, check the new conversion log and see if a new form is referenced and repeat previous steps
- If file still does not convert, contact technical support