Summary
When opening a company, the "Opening Database. Please Wait..." window hangs.
Cause
- The MySQL Connector maybe damaged
- File / Folder location maybe compressed - Sage 50 cannot open compressed files
- The connection to the server may be bad
- Computer is waiting for reboot after Windows Update
- Computer is missing windows updates
Resolution
CAUTION: Sage Customer Support cannot assist with issues related to third-party products or enhancements, hardware, report customizations, state or federal tax-related questions, or specific accounting questions. Refer to our Scope of Support document for details. For assistance, contact your Sage business partner, network administrator, or accountant.
Method 1: It happens when opening the sample company
- Go to Start, Control Panel, Programs and Features.
- Uninstall Sage 50 Accounting Version 20xx.
- Reinstall Sage 50.
- Reboot the computer.
- Open the sample company - How do I open the sample company?
- If it opens, open your company data
Method 2: Initiate Windows updates
- Check all computers for Windows updates.
- Reboot the main computer and the workstations to complete any Windows updates.
- Open the sample company - How do I open the sample company?
- If it opens, open your company data
Method 3: Uninstall the MySQL Connectors
- Go to Start, Control Panel, Programs and Features.
- Uninstall MySQL Connector/ODBC 3.51 and MySQL Connector/ODBC 5.2(a).
- Reinstall the MySQL Connectors (C:\Sage\Sage 50 Accounting Installer Files XXX\BIN\MySQLODBC\).
- Reboot the computer.
- Try to open your company files again.
Method 4: Check for compressed folders
- Check the company filename in Windows Explorer and ensure it does not have blue arrows like in the image below:
- If there are blue icons on the data folder location, right-click the folder where the data is located and go to Properties, Advanced.
- Ensure Compress contents to save disk space is unchecked
- Ensure Compress contents to save disk space is unchecked
Method 5: Remove simplyxxx.ini file
- Restart the computer.
- Open C:\Users\userxxx\AppData\Local\Simply Accounting
- If Appdata folder is not showing on the file explorer window go to View and click Hidden items
- If you are using Sage 50 2024, delete the simply310.ini file.
- Simply 300.ini for 2023 version
- The latest version will be the last date modified
- Delete only the simplyxxx.ini file specific to the Sage 50 version that you cannot open
- Simply 300.ini for 2023 version
- Reboot your computer.
- Open the sample company - How do I open the sample company?
- If it opens, open your company data