Skip to content
logo Knowledgebase

Erreur : " Impossible d'ouvrir le fichier d'entreprise, des fichiers de données sont manquants... "

Created on  | Last modified on 

Summary

Comment résoudre l'erreur : " Impossible d'ouvrir le fichier de l'entreprise [nom du fichier]. Un fichier de données requis est manquant. Vérifiez votre répertoire de données pour vous assurer que les fichiers sont présents " lors de l'ouverture d'un fichier de données ou d'une restauration à partir d'une sauvegarde dans Sage 50 Comptabilité.

Cause

  • Le raccourci SAI ou le dossier SAJ est manquant ou a été renommé
  • La dernière version du programme n'est pas installée
  • Le fichier est situé dans un dossier synchronisé avec des services cloud comme One Drive, Google Drive ou Drop Box
  • Les fichiers du dossier SAJ sont en statut caché dans Windows

Resolution

Le fichier est partagé sur l' Accès aux Données à Distance

  1. Téléchargez à nouveau les fichiers à partir de l'accès aux données à distance.
    • Si vous avez des difficultés à retélécharger ce fichier, essayez d'ouvrir le fichier sur un l'ordinateur d'un autre utilisateur de l'accès à distance en tant que sysadmin et en mode mono utilisateur
    • Si le fichier s'ouvre bien sur un autre ordinateur, allez dans Fichier, Accès aux données à distance, Suspendre le partage puis retourner dans Fichier, Accès aux données à distance, Reprendre le partage
    • Télécharger à nouveau le fichier sur l'ordinateur qui a un problème
  2. Enregistrer le fichier sur C:\Sage.

Déplacer le fichier vers le disque C

  1. Copiez le fichier d'entreprise (fichier SAI et dossier .SAJ) dans un nouveau dossier du lecteur C:\\ et vérifiez que vous pouvez ouvrir le fichier maintenant.
  2. Assurez-vous que l'emplacement des fichiers entreprise ne soit pas sur un nuage (OneDrive, Dropbox, GoogleDrive,...) et ne soit pas synchronisé avec un tel nuage.
  3. Si vous ne pouvez toujours pas ouvrir le fichier de l'entreprise, restaurez à partir d'une copie de sauvegarde.
  4. Contactez le support technique de Sage 50, si vous n'avez pas de sauvegarde.

Restaurez à partir d'une copie de sauvegarde

  1. Restaurez à partir d'une copie de sauvegarde.
  2. Vérifiez que le fichier s'ouvre sans erreur.

Désactiver l'antivirus et le pare-feu

  1. Désactiver temporairement l'antivirus et le pare-feu.
  2. Vérifiez que le fichier s'ouvre.
  3. Si le fichier s'ouvre, configurez l'antivirus pour qu'il autorise les processus Sage 50.

Le fichier icône (.SAI) ou le dossier de données (.SAJ) est manquant 

  1. Vérifiez que vous avez à la fois le fichier icône Sage 50 (.SAI) et le dossier de données (.SAJ) pour votre entreprise au même endroit, dans le même répertoire.
  2. Si vous avez par mégarde supprimé ou modifié l’emplacement d’un des deux éléments, essayez de restaurer l’élément depuis votre corbeille ou de le remettre à son emplacement d’origine.

Le fichier icône (.SAI) et le dossier de données (.SAJ) n'ont pas de noms correspondants

  1. Vérifiez qu’il n’y a pas d’espaces ou de caractères en trop dans le nom du .SAI ou du .SAJ.
  2. Renommez le .SAI ou le .SAJ de façon à avoir exactement le même nom pour les deux éléments.

Fichiers ou dossiers manquants dans le dossier .SAJ

Le dossier SAJ doit normalement contenir les fichiers/dossiers suivant:

Image

  1. Si l'un des éléments ci-dessus est manquant, effectuez une recherche Windows pour les fichiers/dossiers manquants qui ne se trouvent pas dans un dossier .SAJ avec ces noms.
  2. Si vous ne parvenez pas à trouver ces fichiers dans une recherche Windows, restaurez les données de l'entreprise à partir d'une sauvegarde.