Summary
How to solve the error: "Sorry about this" and "It looks like we're experiencing a technical problem" with Bank Feeds in Sage Accounting.
Description
I'm trying to connect or import my bank statement into my ledger. I get an error saying, 'We're experiencing a technical problem when clicking "Connect Bank" or "Import".

Cause
Business Information is missing.
Resolution
- Hover over your Company name at the top right of the account.
- Select Manage Business Account.
- Enter all information within the business information including the Province.
- Select Save.
- Select Go Back to Product.
- Select Settings.
- Select Business Settings.
- Select About your Business.
- Enter all information.
- Select Save.
- Retry to connect bank.