Error: "Invalid file format for file 'XXXXXXX.DAT'"
Description
Cause

There's an error in the formatting of the generated data file.

Resolution

National Bank rejecting the EFT file

If you're uploading the EFT file to National Bank and you get the error message: "Name of the file is invalid":

  1. Check prior uploads of EFT file on your account to get the Name TFXXXXXXXXXX (X being digits).
  2. Rename the EFT file that you're trying to upload with the TFXXXXXXXXXX name. Change the extension to .txt.
  3. Re-upload the EFT file.

Other banks rejecting the EFT file

1. Verify company bank information is correct

  1. From the main screen of Sage 50, click Setup then Settings.
  2. Click Company, then Payment processing.
  3. Select EFT direct and click Modify existing banks.
  4. Select the banking information you’re using to generate the file and select Edit.
  5. Verify that all information is accurate. Fill out all the fields that the bank requires.
    • Not all banks require every field, but if a field that your bank requires is missing, they'll reject the file
    • Some fields that Sage 50 doesn't require, but some banks require include the Company abbreviation and Data Centre No.
    • If you’re not sure which fields the bank requires, contact your bank
  6. If you found an error, correct it and click OK and then OK again to save the changes.

2. Verify employee, vendor, or customer bank information is correct

  1. Open your list.
  2. Select the first employee, vendor, or customer payment that you included in the file that the bank rejected.
  3. Select Direct deposit (for customer records, select Pre-Authorized Debit).
  4. Confirm the banking information for the employee, vendor, or customer is correct.
  5. Repeat the same steps for each record that you included in the rejected file.
  6. If you found an error, correct it and note the record on which you changed the information.
  7. Repost the transactions that you need to upload to the bank to pull the updated banking information.

3. Verify the information used when generating the file is correct

  1. Go to File, Import/Export, then Upload Direct Payments.
  2. Select the type of file you want to generate.
  3. Select the transactions you want to include in the file.
  4. Change the Status from Not Generated to All to see the transactions that were already in the rejected file.
  5. Click Upload.
  6. Make sure the options you selected on this screen are correct. The most likely option to cause a rejection is an incorrect Creation No.
  7. If you’re not sure what creation number the bank is looking for, contact your bank to obtain the next creation number they’re expecting.
  8. Click Next, and then Save this EFT Direct file.
  9. Note the file name and location where you're saving the file. 

General troubleshooting tips

  • If this is the first time setting up Sage 50 EFT, pay special attention to the Bank name field. Some banks prefer CPA Standard.
  • If the bank has accepted other files using the same company settings, then the issue is in a new record or the file you generated.
    • Common problems include an incorrect creation number or saving the file in a different location than normal.
  • If the bank can provide a sample file, see Understanding the EFT-generated .DAT files.

Data Center Numbers

  • The CPA Standard for Scotiabank is 00220
[BCB:159:Chat 50 CA English:ECB]

 

 

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