Use the *UFAC utility to check damaged files
Description
Cause

Use *UFAC to check files before running the *UFAR utility

Resolution
  1. Make a backup of the file you’re repairing.
     TIP: Copy the corrupted file to C:\ root, then run the utility with that file. Rename the original file, then paste the new one back once the utility completes the process. 
  2. Start the *UFAC utility:
    • Via Windows Explorer, go to the "..\MAS90\HOME" directory where Sage 100 ERP is installed
    • Right-click the Pvxwin32.exe file
    • Select "Run as Administrator"
    • Click OK at the ProvideX:Initialization
    • In the ProvideX window, enter the following command at the prompt and press the Enter key:
      RUN "*UFAC"
  3. Enter the name of the file you’re repairing at the Name of Keyed file field. Use the full path to that file and press the Enter key.
    For example, If you followed the suggestion in Step 1, and the file you’re checking is GL_DetailPosting.m4t. The path is C:\GL_DetailPosting.m4t.
  4. For "Pause at each error?" enter (Y) or (N).
    • Yes: Stop after each error.
    • No: Continue processing, reporting the total number of errors at the end of the run.
  5. For Display index trace, enter (Y), (N), or (Q).
    • Yes: The utility displays the various keyed index entries as the utility verifies.
    • No: Prevent trace of the index entries.
    • Quit: Exit the utility.
  6. For Log errors to printer, enter (N), (Y), or (Q).
    • No: Displays the errors on screen.
    • Yes: Displays and prints an Error Log.
    • Quit: Exit the utility.
  7. Click the Close (or "x") button to close the Application window.
  8. Enter the BYE and press the Enter key to exit.
[BCB:155:Chat 100 US:ECB]

 

Steps to duplicate
Related Solutions

Rebuild Key Files in Sage 100
Use the *UFAR utility to rebuild files