Error: "Pervasive Status Code 161" - No permanent Pervasive Key
Description

Possible full error

"This program has quit. Pervasive status code 161. Your system has reached the maximum number of licenses. This situation can occur when the Pervasive Server engine shuts down and another workstation takes control of the processing. TS 2696"

Cause

There's a Pervasive/Actian license that's inactive, failed, disabled, or is a temporary license.

Resolution
[BCB:3:Network warning:ECB]

Information

  • If the repair process fails, contact Sage Support for further assistance
  • You can't repair a temporary license

Versions 24.2 and later

  1. Go to Windows Start, All Programs, Sage Administration, License Administration.
  2. Clear the Hide Expired checkbox in the lower left corner.
  3. Go to Actian Licenses.
  4. Click Authorize a New Product Key.
  5. A new key should populate in the table.
  6. Close License Administration.

Versions 16.1 to 24.1

  1. Go to Start, All Programs, Actian PSQL 12, PSQL License Administrator.
  2. Clear the Hide Expired checkbox in the lower left corner.
  3. Click the inactive, failed, or disabled Actian PSQL 12 key.
  4. Click the Repair button.
  5. After the repair completes, log in to the software.

Versions 15.1 and older

  1. Go to Start, All Programs, Pervasive PSQL 11, Utilities, Pervasive License Administrator.
  2. Clear the Hide Expired checkbox in the lower left corner.
  3. Click the inactive, failed, or disabled Pervasive PSQL 11 key.
  4. Click the Repair button.
  5. After the repair completes, log in to the software.
Steps to duplicate
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