When I go to Help, Upgrade Your Sage 50 Product and click OK, nothing happens and there is no error message
Description
Cause
  • you are using the incorrect serial number (eg., 2021 serial number for 2022 - they change every year)
  • your company name or client ID don't match our records
  • you don't have an internet connection
  • you may have received a faulty serial number and activation key
Resolution
  • If you are sure that all your registration information is correct and you are using the correct serial number for that version:

 

[BCB:159:Chat 50 CA English:ECB]



Steps to duplicate
Related Solutions