Sage 50 freezes when creating a backup
Description

Q: Is it okay to delete temp files?

A: "Yes, they can, and should be, deleted periodically."

Microsoft Community

Cause

Caused by saving backups or other files inside the company SAJ folder.

Resolution

Option A:

Step 1:

  1. Right click Sage 50 icon.
  2. Click properties.
  3. Uncheck the box "Run this program in compatibility mode for" in Compatibility tab.

Step 2:

  1. Go to File, Properties.
  2. On the Location line, click on the blue link to open the folder where your company data is located
  3. Create a new folder named "Backup", if one does not already exist.
  4. Go into the .SAJ folder and verify the following:
    • For versions 2013 and Older:
      Folders: mysql; simply
      Files: ib_logfile0, ib_logfile1, ibdata1, you may also have some text files
    • For 2014 and newer
      Folders: mysql; simply; performance_schema
      Files: ib_logfile0; iblogfile1; ibdata1; auto.cnf and you may also see some various text files
  5. Move all the .CAB files (compressed backup files) listed in Step 4 to the "Backup" folder created in Step 3.
    • Also verify in each of the subfolders (mysql, simply and performance_schema) that there are no other folders or .CAB files located in them as well, if so also move them out of the .SAJ folder
  6. Create another backup and make sure to change the path to point it to the newly created "Backup" folder created in Step 3.
  7. Check the location of the automatic backup by going to Setup, Settings, Company, Backup and make sure that the path in "Scheduled Backup" is not pointing to an .SAJ folder.

Step 3: To "cleanup" the rest of the computer of these large backup files

  1. Delete the contents of the TEMP folder
    • In Windows Vista/7/8, go to "Start" and type "%temp%" in the 'search box' and press on "Enter" button.
    • CTRL + A, to select all.
    • Delete key, to delete all the files and folders in this location.
  2. Delete the large .CAB files located in the auto backup folder (from Step 1, substep 7 above).
  3. Delete all or most of the .CAB files (from step 5 above) as there is no point to save these large files.

Step 4: Warning about restoring affected backups

  1. Please be aware that if you restore any backup files that have .CAB files within the SAJ folder, then this problem will repeat itself again.
  2. To prevent this, Sage suggests to:
    1. Restore each backup.
    2. Clean up the SAJ content as per Step 1.
    3. Create a new version of this backup and overwrite the previous backup instance.
    4. Repeat until all of your backups no longer have .CAB files in the SAJ folder.


Option B: High CPU but low disk usage when creating a backup in 2017.x

Warning: Modifying the Windows registry without knowledge or expertise can cause computer damage. Seek a computer professional


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