Common issues caused by a large Log Viewer file (QLM)
Description
Cause

Issues that can occur due to a large Log Viewer

  • False Pervasive Status Code 2 errors
  • False Pervasive Status Code 54 errors

Interfacing applications

If interfacing software uses an ODBC connection, it logs entries to the Log Viewer every time it syncs or makes a connection. This can cause multiple entries because of the continuous syncing, some programs will continue to sync overnight.

Slow performance in Sage 300 CRE

How do I troubleshoot slow performance in Sage 300 Construction and Real Estate and Sage Estimating?

Files in use, files locked open, or error TS 2606

ODBC errors

Error: "[42000] [Sage][SQLEngine] (31732) Driver is read-only and does not permit UPDATE operations."

Resolution

Identify the size of the Log Viewer file

  1. Launch Windows Explorer.
  2. Browse to the Global folder on the server.
    • C:ProgramData\Sage\Timberline Office\9.5\Accounting\Global
    • \\[ServerName]\Timberline Office\9.5\Accounting\Global\
  3. In the Global folder, open the PVData folder.
  4. Right-click on the master_qlm folder, then select Properties.
  5. Make note of the Size.

When the master_qlm size is approaching 2GB, archive the Log Viewer.

Steps to duplicate
Related Solutions

Log In/Out entries from interfacing software are filling the Sage Log Viewer